AxisPay Status Page - NICE Outage 3/23/25 – Incident details

All systems operational

NICE Outage 3/23/25

Resolved
Operational
Started 7 months agoLasted 10 minutes
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Update
    Update

    We are continuing to work on a fix for this issue.

  • Identified
    Identified

    We are currently experiencing an issue with our phone and chat systems, neither system is able to accept contacts at this time. In the interim, please contact us at shift4.com/support using our webform contacts.